Monday, 22 July 2013

ทำ Load Balance เน็ต 2 สายด้วย MikroTik RB750, RB751U, RB450G

คุณสมบัติอีกอย่างหนึ่งที่โดดเด่นของ MikroTik ที่ไม่แพ้ Hotspot ก็คือการทำการรวมเน็ตมากกว่าสองเส้นขึ้นไปมาเป็น Load balance นั่นเองครับวันนี้เราจะมาดูว่าทำยังไงกันครับ ในที่นี้ผมจะใช้ RB750 ในการสาธิตนะครับแต่ถ้าจริงๆ แล้วรุนอื่นๆ ก็ตั้งค่าเหมือนกันหมดเลยครับ

นี้คือ Diagram ที่เราจะต่อกันนะครับ


เริ่มจากเมื่อเราเชื่อมต่อเข้า MikroTik RB750 จะมีหน้าถามให้ติดตั้ง Default Configuration ให้เลือก OK ครับ


โดย Default Configuration ตัว RB750 จะสามารถต่อเน็ตได้อยู่แล้วโดย Port 1 ต่อกับเน็ต ISP และ Port 2 3 4 5 ทำหน้าที่เป็น Local Lan ภายใน

ก่อนที่เราจะทำอะไรกับ MikroTik เราต้องไปแก้ IP Modem ของเราก่อนนะครับให้เป็น 192.168.10.1 และ 192.168.20.1 ตามลำดับที่แสดงไว้ในไดอแกรมนะครับ ส่วนขั้นตอนการเปลี่ยน IP ของ Modem ของแต่ละรุ่นนั่นไม่เหมือนกันต้องอ่านจากคู่มือของแต่ละรุ่นเอานะครับ


ขั้นตอนต่อไปเราจะทำการ Reset Configuration ทั้งหมดเพื่อตั้งค่า 2WAN to 3LAN นะครับ


เลือกตามรูปนะครับ


จากนั่นรอสัก 30 วินาทีครับ เครื่องจะบอกว่า Disconnect ให้เราต่อกับ RB750 ใหม่


จากนั่นเชื่อมต่อ RB750 ด้วย Mac Address ตามรูป


จากนั่นให้ตรวจสอบดูก่อนว่า Port ทั้งหมดนั่นเป็น Ethernet หรือเปล่า


ต่อไปเราจะตั้งค่าโดยใช้ Terminal กันนะครับโดยโคดสามารถดาวโฟลดได้ที่นี้ คลิ๊ก หรือว่าก็อบปี้จากด้านล่าง

#|
#|
#| Define all parameters
#|
#|
:global wanAddress1 192.168.10.2/24
:global wanNetwork1 192.168.10.0
:global wanNetwork1Subnet 192.168.10.1/24
:global wanBroadcast1 192.168.10.255
:global wanGateway1 192.168.10.1

:global wanAddress2 192.168.20.2/24
:global wanNetwork2 192.168.20.0
:global wanNetwork2Subnet 192.168.20.1/24
:global wanBroadcast2 192.168.20.255
:global wanGateway2 192.168.20.1

:global localAddress 192.168.88.1/24
:global localNetwork 192.168.88.0
:global localNetwork2 192.168.88.0/24
:global localBroadcast 192.168.88.255
:global localGateway 192.168.88.1
:global localDNS 192.168.88.1
:global localPool 192.168.88.10-192.168.88.200

:global dnsServer 8.8.8.8,8.8.4.4

#|
#|
#| Assign interace's name
#|
#|
/interface set "ether1" name="PORT1_WAN"
/interface set "ether2" name="PORT2_WAN"
/interface set "ether3" name="PORT3_LAN"
/interface set "ether4" name="PORT4_LAN"
/interface set "ether5" name="PORT5_LAN"


#|
#|
#| Assign master port switch
#|
#|
/interface ethernet set PORT4_LAN,PORT5_LAN master-port=PORT3_LAN


#|
#|
#| Assign ipaddress to our interfaces
#|
#|

#| Port 1 -> WAN 1
/ip address add address=$wanAddress1 network=$wanNetwork1 broadcast=$wanBroadcast1 interface=PORT1_WAN

#| Port 2 -> WAN 2
/ip address add address=$wanAddress2 network=$wanNetwork2 broadcast=$wanBroadcast2 interface=PORT2_WAN

#| Port 3 -> Local LAN
#| Port 4 -> Local LAN
#| Port 5 -> Local LAN
/ip address add address=$localAddress network=$localNetwork broadcast=$localBroadcast interface=PORT3_LAN


#|
#| Mark incoming package on input's chain
#|
/ip firewall mangle add chain=input in-interface=PORT1_WAN action=mark-connection new-connection-mark=PORT1_WAN_conn
/ip firewall mangle add chain=input in-interface=PORT2_WAN action=mark-connection new-connection-mark=PORT2_WAN_conn


#|
#| Mark routing package on output's chain
#|
/ip firewall mangle add chain=output connection-mark=PORT1_WAN_conn action=mark-routing new-routing-mark=to_PORT1_WAN
/ip firewall mangle add chain=output connection-mark=PORT2_WAN_conn action=mark-routing new-routing-mark=to_PORT2_WAN


#|
#| Accept all packages if they come from local
#|
/ip firewall mangle add chain=prerouting dst-address=$wanNetwork1Subnet action=accept in-interface=PORT3_LAN
/ip firewall mangle add chain=prerouting dst-address=$wanNetwork2Subnet action=accept in-interface=PORT3_LAN

#|
#| Do the load balance package
#|
/ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=PORT3_LAN per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=PORT1_WAN_conn passthrough=yes
/ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=PORT3_LAN per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=PORT2_WAN_conn passthrough=yes

#|
#| Mark output network for packages
#|
/ip firewall mangle add chain=prerouting connection-mark=PORT1_WAN_conn in-interface=PORT3_LAN action=mark-routing new-routing-mark=to_PORT1_WAN
/ip firewall mangle add chain=prerouting connection-mark=PORT2_WAN_conn in-interface=PORT3_LAN action=mark-routing new-routing-mark=to_PORT2_WAN


#|
#| Add routing table
#|
/ip route add dst-address=0.0.0.0/0 gateway=$wanGateway1 routing-mark=to_PORT1_WAN check-gateway=ping
/ip route add dst-address=0.0.0.0/0 gateway=$wanGateway1 distance=1 check-gateway=ping


/ip route add dst-address=0.0.0.0/0 gateway=$wanGateway2 routing-mark=to_PORT2_WAN check-gateway=ping
/ip route add dst-address=0.0.0.0/0 gateway=$wanGateway2 distance=2 check-gateway=ping


#|
#|
#| Assign NAT
#|
#|
/ip firewall nat add chain=srcnat out-interface=PORT1_WAN action=masquerade
/ip firewall nat add chain=srcnat out-interface=PORT2_WAN action=masquerade


#|
#|
#| Assign allow DNS
#|
#|
/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=$dnsServer


#|
#|
#| Assign DHCP server
#|
#|
/ip pool add name=default-dhcp ranges=$localPool
/ip dhcp-server add name=default address-pool=default-dhcp interface=PORT3_LAN disabled=no
/ip dhcp-server network add address=$localNetwork2 gateway=$localGateway dns-server=$localDNS


จากนั่นให้ก็อบโคดแล้ววางใน Terminal นะครับ


จะได้ประมาณนี้ครับ


ผลจากการรัน Script นั่นจะทำให้เราได้ Firewall, DHCP Server, Interface List และ Routing ตามนี้





จากนั่นเมื่อเราทดสอบลองเล่นเน็ตดูก็จะเห็นว่าทั้ง 2 WAN นั่นทำงานได้แล้วครับ


เพียงเท่านี้เราก็มี Load Balance ราคาถูก คุณภาพดีใช้งานแล้วละครับ

96 comments:

  1. สอบถามครับ ไม่ทราบว่าวิธีนี้เป็นการรวมเน็ตสองเส้น หรือ line backup โดยเวลา lineไหนมีปัญหาก็จะสลับไปอีก link ที่ใช้งานได้ให้อัตโนมัติ

    ReplyDelete
  2. ทั้งสองอย่างครับถ้า online ทั้งสองจะเป็นรวมกันครับ
    แตุ่้าเหลือเส้นใดเส้นหนึ่งจะทำงานเป็น backup ครับ

    ReplyDelete
    Replies
    1. สอบถามนิดนึงครับ

      ถ้า WAN นึงเป็น ADSL และ อีก WAN นึงเป็น 3G Router

      ผมต้องการทำเป็น Active - Backup โดยในภาวะปกติให้ Traffic วิ่งที่ ADSL ก่อน ต้องแก้ Script อย่างไรครับ

      ขอบคุณครับ
      สุทัศน์

      Delete
  3. ไม่ทราบสคริปนี้เป็น Load balance แบบ PCC รึเปล่าครับแล้วช่อง ether3 -ether5 นั้นต้องการให้ใช้เป็น hotspot จะต้องเพิ่มเติมหรือแก้ส่วนไหนครับ
    ความต้องการของผม คือ 1. ทำload balance แบบ pcc รวมเน็ต 2 เส้น
    2.hotspot
    3.block bit

    ครับ

    ReplyDelete
    Replies
    1. ครับเป็นแบบ PCC ครับ Port 3 - 5 ทำเป็น Switch ไว้ครับถ้าเป็น Hotspot ก็ทำได้เลยครับ

      Delete
  4. ผมได้เซ็ท โมเด็ม เป็น บริดจ์โหมดและตั้งค่าให้ microtiik ppoe ต่อเน็ตเอง จากนั้น ผมลองต่อเข้าสวิทช์ที่ Port 3 หรือ 4 หรือ 5 แล้ว ไม่สามารถเข้า internet ได้ ครับทั้งที่ pppoe ของmicrotik คอนเน็คเน็ตแล้วครับ และลองเซ็ทที่ hotspot ของ microtik ก็ออกเน็ท ไม่ได้ครับ โดยใช้ port 3

    ReplyDelete
    Replies
    1. Script ด้านบนไม่ได้รองรับการทำงาน บริดจ์โหมด ครับ
      ด้านบนรองรับการแจก DHCP จากโมเด็มครับ

      Delete
  5. เน็ต cat on net กับ tot winet จะแก้ dsn ใส่ตรงไหนครับ

    ReplyDelete
  6. แก้ที่ IP => DNS ครับ

    ReplyDelete
  7. ลองดูแล้วเป็นแค่ line backup ไม่ได้ Load balance

    ReplyDelete
    Replies
    1. Load balance ครับลองดูดีดี

      Delete
    2. ผมก็ลองแล้วมัน active ไม่พร้อมกันครับ มันจะวิ่งแค่เส้นเดียว ถ้าถอดเส้นที่วิ่งออกมันจะไปวิ่งอีกเส้นครับ ชี้แนะด้วยครับ

      Delete
  8. ผมทำตาม ด้านบนแล้วครับ

    แล้วก้อ ทำ hotspot ต่อครับ

    ผล คือ เน็ตใช้ได้ แต่ หน้า login ไม่ขึ้น อัตโนมัติ ครับ ต้องพิมพ์ 192.168.88.1 ครับ

    ถึงจะเข้า ระบบได้

    มีวิธีแก้ ไหมครับ

    ReplyDelete
    Replies
    1. MikroTik ยังไม่สามารถออกเน็ตได้ครับกรณีนี้ให้ตรวจดูตามนี้ครับ
      - DNS
      - Wan Interface

      Delete
  9. ท่านใดที่ก็อบสคริปไปแล้วสใช้ไม่ได้น่าจะเป็นจากการที่ยังไม่ได้เปลี่ยน IP Modem นะครับยังไงลองเปลี่ยนเป็น 192.168.10.1 192.168.20.1 ดูนะครับน่าจะใช้งานได้ครับ

    ReplyDelete
    Replies
    1. รบกวนขอสคริปทำ load balance เน็ต3 เส้น หน่อยครับพี่ pStudioDev
      port 1 รับจาก modem โดยตรง ip192.168.10.1
      port 2 รับจาก modem โดยตรง ip192.168.10.2
      port 3 รับมาจาก wifi บ้านเพื่อน ip192.168.10.3
      port 4 ว่าง
      port 5 ว่าง (ทำ hospot)
      เน็ต tot ทั้ง 3 เส้นเลยครับ ช่วยหน่อยนะครับพี่

      Delete
    2. เปลี่ยนให้เป็นคนละวง ไม่งั้นก็ไม่ได้ตลอดไป

      Delete
  10. ผมเปลี่ยน ip ตาม แล้วครับ

    เน็ตออก ใช้งานได้

    ยกเว้น หน้า login ครับ

    ReplyDelete
    Replies
    1. Script นี้ไม่มีการทำหน้าล๊อกอินนะครับ
      ต้องทำ Hotpsot แยกครับ

      Delete
  11. ขอบคุณครับ เพิ่งหันมาเล่น ไมโครติ๊ก
    ขอบคุณสำหรับความรู้

    ReplyDelete
  12. ผมเป็น user ขอเรียนถามครับ เผอิญไม่มีความรู้เรื่องนี้เลย
    ถ้าผมต้องการต่อเน็ต 2 สาย ตาม Diagram ด้านบน แบบ wifi เท่านั้น
    และไม่ต้องการเอาเครื่อง server มาตั้งเพื่อแจก ip ครับ พอจะมีวิธีไหมครับ

    ReplyDelete
    Replies
    1. ไม่ต้องมี server ครับ mikrotik จัดการแทนได้หมดครับ

      Delete
  13. ผมทำตามแล้วได้นะครับ rb750gl
    port 1 - 2 ทำ load balance
    port 3 เข้า switch ปล่อยผ่าน lan ในร้าน
    port 4 เข้า Nano M2 ปล่อย wifi
    port 5 ว่าง

    ปล.ผมให้ modem แจก ip นะครับ
    192.168.1.1 = mikrotik
    192.168.2.1 = modem 1
    192.168.3.1 = modem 2 (ตัวนี้เป็น wifi ดึงเน็ตบ้านหลานมาใช้)

    ReplyDelete
    Replies
    1. ทำได้อยู่แล้วครับเพราะคนเขียนบทความนี้หล่อ ฮ๋าๆ

      Delete
    2. เกี่ยวกันอย่างแรงเลยครับ คิคิ

      Delete
  14. ขออนุญาตถามต่อ

    ผมอยากกำหนด banwidth ของ port2 (ไวไฟบ้านหลาน) ได้มั๊ยครับ
    หรือทำเป็น line backup เฉยๆ ก็ได้
    เพราะเวลาใช้งานเต็มๆ มันดึงเน็ตเค้ามาหมดเลย

    ขอบคุณครับ

    ReplyDelete
    Replies
    1. ทำได้ครับให้หาบทความในเว็บนี้ละครับเรื่อง Queue ครับจะ Limit BW ได้ครับ

      Delete
  15. ถ้า wan1 wan2 เป็น pppoe ละครับ แก้ตรงไหนบ้าง ขอบุณครับ

    ReplyDelete
    Replies
    1. ลองดูคล้ายๆ แบบนี้ครับ

      #|
      #|
      #| Define all parameters
      #|
      #|
      :global pppoeName1 pppoe-wan-3bb
      :global pppoeUsername1 wmz7tkyvsb@3bb
      :global pppoePassword1 uuQfBi7L

      :global pppoeName2 pppoe-wan-tot-1
      :global pppoeUsername2 y23722902@tothome
      :global pppoePassword2 y23722902

      :global pppoeName3 pppoe-wan-tot-2
      :global pppoeUsername3 023270250@tothome
      :global pppoePassword3 023270250

      :global localAddress 10.10.0.1/16
      :global localNetwork 10.10.0.0
      :global localNetwork2 10.10.0.0/16
      :global localBroadcast 10.10.255.255
      :global localGateway 10.10.0.1
      :global localDNS 10.10.0.1
      :global localPool 10.10.0.100-10.10.254.254

      :global dnsServer 8.8.8.8,8.8.4.4

      #|
      #|
      #| Assign interace's name
      #|
      #|
      /interface set "ether1" name="port1-wan"
      /interface set "ether2" name="port2-wan"
      /interface set "ether3" name="port3-wan"
      /interface set "ether4" name="port4-lan"
      /interface set "ether5" name="port5-lan"


      #|
      #|
      #| Assign master port switch
      #|
      #|
      /interface ethernet set port5-lan master-port=port4-lan


      #|
      #| PPPOE Setup
      #|
      /interface pppoe-client add name=$pppoeName1 user=$pppoeUsername1 password=$pppoePassword1 use-peer-dns=yes add-default-route=yes interface=port1-wan disabled=no
      /interface pppoe-client add name=$pppoeName2 user=$pppoeUsername2 password=$pppoePassword2 use-peer-dns=yes add-default-route=yes interface=port2-wan disabled=no
      /interface pppoe-client add name=$pppoeName3 user=$pppoeUsername3 password=$pppoePassword3 use-peer-dns=yes add-default-route=yes interface=port3-wan disabled=no

      Delete
  16. ได้ลองทำตาม สคริป แล้วออกเน็ตได้แล้ว แต่ว่ามาทำ hotspot แล้วเครื่องลูก connect แล้วได้รับ ip แล้วแต่ว่าเวลาเข้าเวปมันไม่ redirect ไปหน้า login ของ hotspot ครับ รบกวนแนะนำด้วยครับ

    ReplyDelete
    Replies
    1. ลองดูที่ IP -> Firewall -> Mangle นะครับจำไม่ได้ว่า Rule ที่ 5 6 หรือเปล่าให้เลือก Hotspot = auth นะครับน่าจะใช้ได้เลยครับ

      Delete
    2. This comment has been removed by the author.

      Delete
    3. ถ้างั้นคงต้องไล่ดูตามนี้ครับ IP->DNS, IP->Firewall->NAT ครับน่าจะมีอะไรผิดสักอย่างอะครับ

      Delete
    4. สอบถามอีกรอบครับ พอดีเทสสคริปแล้วใช้งานได้ Hotspot แก้ตามที่แจ้งก็ออกได้ครับ แต่ว่าลองเข้าเวปไซต์มันช้าครับ จะหมุนนานสักพักก็จะหายครับ ผมทำผิดพลาดตรงไหนแนะนำด้วยครับ

      Delete
  17. ขอความอนุเคาระห์ด้วยคับ ทำใช้ใน รพ.คับ คล้ายกับ หัวข้อ ได้ลองทำตาม สคริป แล้วออกเน็ตได้แล้ว แต่ว่ามาทำ hotspot แล้วเครื่องลูก connect แล้วได้รับ ip แล้วแต่ว่าเวลาเข้าเวปมันไม่ redirect ไปหน้า login ของ hotspot ครับ รบกวนแนะนำด้วยครับ
    ตรง ลองดูที่ IP -> Firewall -> Mangle นะครับจำไม่ได้ว่า Rule ที่ 5 6 หรือเปล่าให้เลือก Hotspot = auth นะครับน่าจะใช้ได้เลยครับ มันไม่อนุญาติให้แก้เลย
    และตรง ถ้างั้นคงต้องไล่ดูตามนี้ครับ IP->DNS, IP->Firewall->NAT ครับน่าจะมีอะไรผิดสักอย่างอะครับ ผมมือใหม่คับพอจะบอกได้ไหมคับว่าจุดไหนเลย ต้องขอรบกวนจริงๆคับ ขอบคุณล่วงหน้าคับ

    ReplyDelete
    Replies
    1. ต้องเมนู WinBox => IP => Firewall => NAT อะครับดูว่าไ้มีการทำ NAT แล้วยังครับประมาณนี้อะคัรบ

      /ip firewall nat add chain=srcnat out-interface=port1-wan action=masquerade

      Delete
  18. แล้วถ้าเน็ตเส้นแรกต่อแบบ pppoe อีกเส้นรับมาจาก wifi จะต้องคอนฟิกแบบไหนครับ

    ReplyDelete
    Replies
    1. ให้เอา script pppoe มารวมกับแบบ static ได้เลยครับ

      Delete
  19. วายทำใด้ไหม
    ครับ

    ReplyDelete
  20. วายเน็ตทำใด้ไหมครัย

    ReplyDelete
  21. รบกวนสอบถามครับ ถ้าความเร็วจาก WAN ไม่เท่ากัน เช่น WAN 1 = 20 Mb, WAN2 = 4 Mb ต้องแก้อะไรหรือเปล่าครับ

    ReplyDelete
    Replies
    1. ไม่ต้องแก้อะไรเพิ่มครับใช้งานได้เลยครับ

      Delete
  22. แล้วถ้า อินเตอร์เน็ตทั้งสอง เส้น เป็น leas line ต้อง set ยังไงบ้างคับในส่วนของ wan พอดีเพิ่งใช้ คับ

    ReplyDelete
    Replies
    1. ทำเป็ฯ static ip ครับ

      Delete
  23. สอบถามหน่อยครับ ผมใช้450g ใช้เน็ต3bb 1เส้น10m และจะเพิ่มอีก1เส้น เป็นของ airnet อีก1 เส้น10m ไม่ทราบว่าจะได้ไหม? 450G ตอนนี้เน็ตเส้นแรกผมเอาเข้าพอร์ต1และออกพอร์ต3พอร์ต2เหมือนมันมีปัญหาครับ...ถ้าต้องการเพิ่มเน็ตอีก1เส้นเข้าไปพอร์ต3และใช้งานพอร์ต4 ต้องแก้ไขโค๊ดตรงไหนบ้างครับความต้องการคืออยากให้รวมเน็ต2เส้นให้ได้เยอะและใช้งานได้เพราะบางที่เน็ต 3bb เสียบ่อยเพราะมันมากับสายdw เลยต้องไปพึ่ง airnet ที่มากับอากาศแทน รบกวนช่วยแนะนำหน่อยครับนั่งงมมาหลายวันแล้วคับ

    ReplyDelete
    Replies
    1. ของ airnet หรือ ynet ก็ทำได้ครับ

      Delete
  24. พี่ครับผม wan1 ผมใช้ของ ais airnet wan2 ผมใช้ของ tot winet ออกเน็ตได้ทั้งสองช่องแต่ถ้าเสียบพร้อมกันเน็ตมันจะช้าไปเลยครับ แก้ตรงไหนได้บ้างครับ

    ReplyDelete
    Replies
    1. คงต้องดูที่ ip routing table ก่อนครับมีหน้าตาไงบ้าง จากนั่นให้ไปดูที่ ip firewall mangle ครับอาจจะมีอะไรบ้างอย่างผิดในน่ั่นครับ

      Delete
    2. มีรูปภาพประกอบไหมครับ..ยังไม่เข้าใจในระบบเท่าไหร่พึ่งหัดทำครับ...

      Delete
  25. ผมเอาสคริปข้างบน รวมเน็ต ช่องที่ 1และ2 ได้แล้ว และก็สามารถเล่นออกเว็บปกติได้ ทั้ง พอร์ตที่ 3,4,5
    แต่พอผมเอาช่องที่ 5 ทำhotspot ช่องที่5ทำไมมันไม่เข้าล็อกอินhotspot เเต่มันรับไอพีและเล่นได้เลยโดยไม่ต้องล็อกอินนะครับ ต้องตั้งค่าตรงไหนเพิ่มเติมมั้ยครับ


    ReplyDelete
  26. รบกวนหน่อยครับ ถ้าผมใช้เน็ต 3 เส้นหรือมากกว่า จะแก้สคริปตรงไหนบ้างครับ

    ReplyDelete
  27. รบกวนอีกคนครับ ถ้าเป็นแบบ 3 WAN ต้องเขียนสคริปเพิ่มอย่างไรบ้างครับ

    ReplyDelete
  28. มี 2 wan ทำ bridge 1 wan(pppoe) กับไม่ได้ทำ bridge 1 wat
    ผมต้องทำ firewall mangle มั้ยครับ

    ReplyDelete
  29. รบกวนขอสคริปทำ load balance เน็ต3 เส้น หน่อยครับพี่ pStudioDev
    port 1 รับจาก modem โดยตรง ip192.168.10.1
    port 2 รับจาก modem โดยตรง ip192.168.10.2
    port 3 รับมาจาก wifi บ้านเพื่อน ip192.168.10.3
    port 4 ว่าง
    port 5 ว่าง (ทำ hospot)
    เน็ต tot ทั้ง 3 เส้นเลยครับ ช่วยหน่อยนะครับพี่

    ReplyDelete
    Replies
    1. ต้องขอโทษด้วยนะคัรบพอดีผมยุ่งมากคัรบ support ลูกค้าตลอดเลยอาจจะต้องรบกวนลองแก้ดูเองก่อนนะครับ ถ้าว่างจริงๆ เดียวผมทำให้ดูนะครับแต่คงอีกพักใหญ่อะคัรบ

      Delete
  30. มือใหม่ mikrotik 450g ครับ

    port 1 รับจาก modem ip192.168.100.2 (tot)
    port 2 รับจาก modem ip192.168.200.2 (true)

    port3,4,5 ออกเน็ตไม่ได้ครับ

    ReplyDelete
  31. มือใหม่ mikrotik 450g ครับ

    port 1 รับจาก modem ip192.168.10.1 (3bb)
    port 2,3,4,5 ต่อกับไวไฟตอนนี้ยังใช้เน็ตไม่ได้ครับ

    ReplyDelete
  32. ยังรออยู่นะครับพี่ ...

    ReplyDelete
  33. รบกวนขอสคริปทำ load balance เน็ต3 เส้น หน่อยครับพี่ pStudioDev
    port 1 รับจาก modem โดยตรง ip192.168.10.1
    port 2 รับจาก modem โดยตรง ip192.168.10.2
    port 3 รับมาจาก wifi บ้านเพื่อน ip192.168.10.3
    port 4 ว่าง
    port 5 ว่าง (ทำ hospot)
    เน็ต tot ทั้ง 3 เส้นเลยครับ ช่วยหน่อยนะครับพี่

    ReplyDelete
  34. รบกวนขอสคริปทำ load balance เน็ต3 เส้น หน่อยครับพี่ pStudioDev
    port 1 รับจาก modem โดยตรง ip192.168.10.1
    port 2 รับจาก modem โดยตรง ip192.168.10.2
    port 3 รับมาจาก wifi บ้านเพื่อน ip192.168.10.3
    port 4 ว่าง
    port 5 ว่าง (ทำ hospot)
    เน็ต tot ทั้ง 3 เส้นเลยครับ ช่วยหน่อยนะครับพี่

    ReplyDelete
  35. ผมทำตามวิธีและสคริปถูกทุกอย่างนะครับ แต่ว่าพอจะวางสคริป ตัว450Gมันเด้งออกครับ มันเป็นเพราะอะไรครับ
    ลองก๊อบวางทีละสคริป ลงได้ครับ แต่ใช้งานไม่ได้ครับ
    ขอบคุณครับ

    ReplyDelete
    Replies
    1. This comment has been removed by the author.

      Delete
    2. แก้ไขคำว่า interface ด้วยครับ มันค้างตรงนั้น

      #|
      #|
      #| Assign interface's name
      #|
      #|
      /interface set "ether1" name="PORT1_WAN"
      /interface set "ether2" name="PORT2_WAN"
      /interface set "ether3" name="PORT3_LAN"
      /interface set "ether4" name="PORT4_LAN"
      /interface set "ether5" name="PORT5_LAN"

      Delete
  36. This comment has been removed by the author.

    ReplyDelete
  37. Script นี้ น่าจะเป็นแบบ Backup รึเปล่าครับ เพราะลองเอาไปใช้งานแล้ว มันทำงานแบบ Backup คือเส้นนึงหลุด อีกเส้นจะทำงานแทน แต่ไม่สามารถทำงานพร้อมกันได้

    ReplyDelete
  38. ลองต่อเน็ตเส้นเดียวเข้า เน็ตไม่ออกเลยครับ ตั้งออก lan3

    ReplyDelete
  39. สอบถามครับ พอดีใช้ mikrotik มานาน ไม่ค่อยเข้าไปตั้งค่าอะไรเลย แต่หลังจากใช้มาเกือบ 5 เดือนจู่ๆก็เริ่มติดๆดับๆ...วิธีแก้ไขคร่าวๆคือจะปิดตัว hub แล้วเปิดมันจะใช้ได้เองอัตโนมัติ แต่หลัง2-3 ชม มันก็จะใช้เน็ตไม่ได้. ผมลบ log และ session ออกทั้งหมดแต่ก็ยังไม่สามารถแก้ได้ รบกวนแนะนำด้วยครับ

    ReplyDelete
    Replies
    1. คงต้องลอง Reset ตั้งค่าใหม่สักครั้งนะครับ อัพเดตระบบ เฟิร์มแวร์บ้างก็ดีครับ

      Delete
  40. This comment has been removed by the author.

    ReplyDelete
  41. ผมจะติดตั้ง Mikrotik ผมรบกวนขอวิธีการรวมเนต 2 เส้น ด้วย Mikrotik ผมลองทำตามแล้ว ออกเส้นเดียวเหมือนเดิมครับ รีเซ็ตหลายรอบ ลองแก้ ก็เหมือน เดิม
    เน็ตของ TOT ADSL 2 เส้น
    รับ IP จาก Modem ครับผมจะติดตั้ง Mikrotik ผมรบกวนขอวิธีการรวมเนต 2 เส้น ด้วย Mikrotik
    รูปแบบการเชื่อมต่อตามนี้ครับ
    โดยช่อง LAN 1-2 เป็น Interface In รับสัญญาณแลนส์ จากโมเด็ม TOT ทั้ง 2 เส้น
    Modem 1 IP 192.168.20.1 in WAN1
    Modem 2 IP 192.168.10.1 in WAN2
    LAN 5 เป็น Out โดยจ่าย IP ออกเป็น OUT 5 192.168.1.xxx
    ผมรบกวนขอ SCRIPT ด้วยครับ
    ขอบคุณครับ

    ReplyDelete
  42. มี SCRIPT คำสั่ง หรือวิธีการทำให้บางเว็บไซต์ออกเน็ตเฉพาะเส้นได้ไหมครับ
    ขอรบกวนด้วยครับ

    ReplyDelete
  43. รบกวนขอสคริปทำ load balance เน็ต2 เส้น + LAN + HotSpot

    port 1 รับจาก modem โดยตรง ip 192.168.10.2
    port 2 รับจาก modem โดยตรง ip 192.168.20.2
    port 3 LAN (เข้าเน็ตไม่ต้องล็อกอิน)
    port 4 LAN (เข้าเน็ตไม่ต้องล็อกอิน)
    port 5 HotSpot (ล็อกอินก่อนเข้าเน็ต)

    ผมรบกวนขอ SCRIPT ด้วยครับ
    ขอบคุณครับ

    ReplyDelete
  44. ผมลองทำตามสคริปแล้ว ปรากฏว่าเส้นเดียวเหมือนเดิมครับ เน็ต WAN1 หลุด มันไม่สลับมาใช้ WAN2 แต่ถ้าถอดสาย WAN1 ออก WAN2 ถึงจะใช้งานได้ครับ

    ต้องทำยังงัยครับ
    ขอบคุณครับ

    ReplyDelete
    Replies
    1. เน็ตสองเส้นค่ายเดียวกันหรือเปล่าครับ ถ้าค่านเดียวกันทำ load balance ไม่ได้คับ

      Delete
  45. ใช้ครับเป็นเหมือนกันครับขอสคริปที่มันรวมกันจริงๆ หน่อยจิครับผม

    ReplyDelete
  46. This comment has been removed by the author.

    ReplyDelete
  47. This comment has been removed by the author.

    ReplyDelete
  48. ขอสอบถามเพิ่มเติมครับ
    ของผม Config แล้ว แต่ต้องการเพิ่ม Config ให้ได้ตามโจทย์จะต้องทำอย่างไร
    WAN1= 100 Mbps Ether 1
    WAN2= 30 Mbps Ether 2

    LAN
    Ether 3 DHCP 192.168.30.1/24
    Bridge1 DHCP 192.168.90.1/22 (Ether 4,5)

    ปกติใช้งานเป็น Link BackUP ถ้าสายใดสายหนึ่ง Down ก็จะสลับเอง
    แต่ที่ต้องการทำเพิ่มคือ ห้องทำงานด้านการเงิน จะใช้เน็ตมากกว่าส่วนอื่น และต้องการให้สัญญาณที่เหลือ 30 จ่ายให้เฉพาะส่วนการเงิน โดยจะ Link จาก Ether 3 ตรงไปเข้า Switch ในห้องการเงิน และจะระงับการให้บริการจุดอื่นไว้ก่อน ที่ใช้งานผ่าน Bridge1 จะต้องทำอย่างไรครับ

    ReplyDelete
    Replies
    1. ของพี่ค่อนข้างหลายขั้นตอนคัรบต้องทำ routing mark คัรบแล้วต้องทำการแบ่งเน็ตคับรบกวนติดต่อทาง LINE: indyitgroup ดีกว่าครับ

      Delete
  49. มีแบบไม่ใช้สคริปบ้างป่าวครับ

    ReplyDelete
    Replies
    1. มีครับเดียวว่างๆ ผมอัดคลิปลงให้คัรบ

      Delete
  50. \คือผมทำ Load Balancing+ Fail Over รวมเน็ตสองเส้น แต่สปีดไม่เตมคับ มันควรจะได้ 25+50 =70 แต่มันมาแค่60
    รึเราอาจจะไม่ต้องสนใจก็ได้คับ
    \เวลาเส้นที่1 Fail Over สลับมาเส้น2 แต่พอ2Fail Over มันไม่กลับไปใช้เส้นที่1 ต้องคอยรีเซตเร้าเตอร์ อยากทราบว่าต้องเพิ่มอะไรหรอคับ

    ReplyDelete
  51. \คือผมทำ Load Balancing+ Fail Over รวมเน็ตสองเส้น แต่สปีดไม่เตมคับ มันควรจะได้ 25+50 =70 แต่มันมาแค่60
    รึเราอาจจะไม่ต้องสนใจก็ได้คับ
    \เวลาเส้นที่1 Fail Over สลับมาเส้น2 แต่พอ2Fail Over มันไม่กลับไปใช้เส้นที่1 ต้องคอยรีเซตเร้าเตอร์ อยากทราบว่าต้องเพิ่มอะไรหรอคับ

    ReplyDelete
  52. ทำตามแล้วเน็ต เล่นไม่ได้ครับผม

    ReplyDelete
  53. ทำตามข้างบนแล้วไม่จ่ายเน็ตครับ ขึ้นป้ายเหลืองครับ
    รุ่น RB450G

    ReplyDelete
  54. ลองไล่ดู ตั้งแต่ WAN ppoeหรือ dhcp มา Address สร้างไอพี่ Dhcp server ออกไปไอพีที่ต้องการ NAT LAN สุดท้าย mangle ว่าเน็ตมากี่เมก ก็ เวท ออกไปตามความแรงเน็ต ผมก็ลองไปมา รีเชทหลายครั้งกินไม่ได้นอนไม่หลับ ลองเยอะๆมันจะเจอปัญหาเรื่อยๆจนเราเข้าใจมัน

    ReplyDelete